Back to overview
Resolved
Celestria API degradation
Aug 22, 2026 at 10:13am UTC
Affected services
Celestria Group Website
Celestria Challenge
Celestria Webhooks
Hargrave Links
Ryanair Connect
Ryanair Flights
Ryanair Links
Resolved
Aug 22, 2026 at 10:25am UTC
All services have now been restored. We continue to investigate the root cause and monitor performance.
Affected services
Created
Aug 22, 2026 at 10:13am UTC
We have identified the root cause of the degradation and are currently investigating.
Affected services