Back to overview
Degraded
Celestria authentication is unavailable
May 30, 2026 at 3:46pm UTC
Affected services
Celestria Group Website
Resolved
May 30, 2026 at 4:18pm UTC
The issue has been resolved.
Affected services
Updated
May 30, 2026 at 4:14pm UTC
We have identified the issue preventing users from logging in and a fix is in place. We are monitoring the new fix.
Affected services
Created
May 30, 2026 at 3:46pm UTC
Celestria authentication is currently unavailable for a small number of users. We are investigating the problem.
Affected services